All systems operational

Resolved
Error message appearing when attempting to open survey links

Started
November 07, 2022 at 10:13 PM
Status
Resolved after about 22 hours

Impact

Operational
Affected
Engage
Survey Participation
  • Resolved

    The issue is now resolved. All functions are fully operational at this time. Thank you for your patience.

  • Monitoring

    We implemented a fix and currently monitoring the result.

  • Investigating

    We are investigating an incident causing an error message to appear when attempting to open survey links. We will begin providing updates via the status page shortly. The status page will be updated every 20 minutes.