K12 Insight - Identified issue with Bing Translate – Incident details

All systems operational

Identified issue with Bing Translate

Resolved
Partial outage
Started 11 months agoLasted about 20 hours

Affected

Let's Talk!

Partial outage from 7:29 PM to 3:42 PM

Let's Talk! Platform

Partial outage from 7:29 PM to 3:42 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Our team has identified an issue with Bing Translate in Let's Talk! as it applies to any setting (Topics, Messages, Landing Pages, FAQs). We are working to resolve this issue asap.