K12 Insight - Identified: Outlook Users - Issue with Activation and Password Reset Emails – Incident details

All systems operational

Identified: Outlook Users - Issue with Activation and Password Reset Emails

Resolved
Operational
Started 24 days agoLasted about 20 hours

Affected

Let's Talk!

Operational from 4:54 PM to 1:13 PM

Let's Talk! Platform

Operational from 4:54 PM to 1:13 PM

Updates
  • Resolved
    Resolved

    The issue is now resolved. For impacted users - those attempting to activate their account or reset their password and using a previous version of Microsoft Outlook - a new activation email or password reset email will need to be sent. We apologize for any inconvenience.

  • Identified
    Identified

    Outlook users who are not using the latest version are experiencing issues with activation emails and password reset emails. Our team has identified the root cause and is working to deploy a fix. As a workaround, please either access the browser-based version of Outlook or update your desktop version. Next update on October 29.