All systems operational

Investigating [Reports of search function that is causing slowness in the system]

Resolved
Operational
Started over 1 year ago Lasted about 1 hour

Affected

Let's Talk!
Let's Talk! Platform
Updates
  • Resolved
    Resolved

    The issue is now resolved. All functions are fully operational at this time. Thank you for your patience.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.

  • Investigating
    Investigating

    We’re currently investigating reports of search function that is causing slowness in the system. We are currently investigating this incident. We apologize for any inconvenience and will post another update as soon as we learn more.