K12 Insight - Monitoring Reported Slowness with Let's Talk and Engage – Incident details

All systems operational

Monitoring Reported Slowness with Let's Talk and Engage

Resolved
Operational
Started about 2 years agoLasted 27 minutes

Affected

Websites

Operational from 4:38 PM to 5:05 PM

K12insight.com

Operational from 4:38 PM to 5:05 PM

Engage

Operational from 4:38 PM to 5:05 PM

Engage Platform

Operational from 4:38 PM to 5:05 PM

Let's Talk!

Operational from 4:38 PM to 5:05 PM

Let's Talk! Platform

Operational from 4:38 PM to 5:05 PM

Updates
  • Resolved
    Resolved

    The issue is now resolved. All functions are fully operational at this time. Thank you for your patience.

  • Monitoring
    Monitoring

    Our team has identified the issue and deployed a fix. We are continuing to monitor the systems to ensure all issues are resolved.