All systems operational

error message to appear when attempting to access Let's Talk and Engage

Resolved
Partial outage
Started over 1 year ago Lasted about 21 hours

Affected

Engage
Engage Platform
Let's Talk!
Let's Talk! Platform
Updates
  • Resolved
    Resolved

    On Wednesday, January 18, 2023, between 1:39 PM EST and 4:35 PM EST K12 Insight customers may have been unable to access or experienced degraded performance on our Let’s Talk and Engage platforms.
    We understand that you rely on the availability and performance of our platforms to serve your community. Please also know the quality of your customer experience is of utmost importance to us. Below you will find the root cause of the interruption. We will update our operating procedures to prevent this issue from recurring in the future, and do not anticipate further problems. We are sorry for any frustration and inconvenience this may have caused you and your community.
    The root cause of the service interruption was due to a server that was taking more time to create user sessions and as a result sessions were being timed out for some users. The issue has been addressed and all platforms are operational.

  • Monitoring
    Monitoring

    Our team has identified the issue and deployed a fix. If you are still having issues please log out and close out your browser and log back in. If you continue to experience issues, please contact our support team at 703-542-9601. We appreciate your patience and understanding.

  • Investigating
    Investigating

    We are continuing to monitor until full performance is established.

  • Identified
    Identified

    We are continuing to monitor until full performance is established.