K12 Insight - Investigating reports of potential service interruption Let's Talk and Engage customer facing landing pages and user logins – Incident details

All systems operational

Investigating reports of potential service interruption Let's Talk and Engage customer facing landing pages and user logins

Resolved
Partial outage
Started 10 months agoLasted about 2 hours

Affected

Engage

Partial outage from 8:08 PM to 9:39 PM

Engage Platform

Partial outage from 8:08 PM to 9:39 PM

Email Delivery

Partial outage from 8:08 PM to 9:39 PM

Survey Participation

Partial outage from 8:08 PM to 9:39 PM

Let's Talk!

Partial outage from 8:08 PM to 9:39 PM

Let's Talk! Platform

Partial outage from 8:08 PM to 9:39 PM

Updates
  • Resolved
    Resolved

    The issue is now resolved. All functions are fully operational at this time. Thank you for your patience.

  • Monitoring
    Monitoring

    Our team has identified the issue and deployed a fix. We are continuing to monitor the systems to ensure all issues are resolved.

  • Investigating
    Investigating

    We are currently investigating reports of a potential service interruption that are impacting Let's Talk and Engage customer facing landing pages and user logins. We apologize for any inconvenience and will post another update as soon as we learn more.