All systems operational

Resolved
Identified: Partial Outage

Started
December 04, 2023 at 4:00 PM
Status
Resolved after about 4 hours

Impact

Partial outage
Affected
Let's Talk!
Let's Talk! Dialogue Submission
Email
Phone and SMS
Let's Talk! Customer App (Mobile)
Let's Talk! Admin App (Mobile)
Let's Talk! Assistant (Chatbot)
Let's Talk! Platform
  • Resolved
    Resolved

    The issue is now resolved. All functions are fully operational at this time. Thank you for your patience.

  • Identified
    Update

    We are currently deploying a fix for this issue - the next update will be when this fix is complete.

  • Identified
    Identified

    We’re experiencing a partial outage affecting tabs loading on Let's Talk. Our team is currently working to restore complete access. We apologize for any inconvenience. Customers may be unable to load the tab when accessing your website. Additionally, some users may experience slow load times when logging into the platform. The next update is in 30 minutes.